UK SDM unable to send invite emails at this time.

Incident Report for StrongDM

Update

StrongDM has identified the issue blocking email delivery for our UK Control Plane. Currently users will not receive emails for the following reasons:
*New user invitations
*Access request workflow notifications (these will still work within the Admin Console and Slack/Teams)
Please note, that Customers using StrongDM's native authentication (username/password) are currently unable to invite new users, but Customers using an external authentication provider are still able to onboard new users.
Posted Jul 10, 2025 - 17:02 UTC

Identified

SDM is currently working to resolve the issue. We will update again once we have additional information.

Standard functionality for those already invited to SDM remains normal.
Posted Jul 10, 2025 - 16:22 UTC
This incident affects: UK Control Plane (Admin UI).